chaoshu的个人博客分享 http://blog.sciencenet.cn/u/chaoshu

博文

sudo aptitude install

已有 841 次阅读 2020-9-3 10:05 |个人分类:Ubuntu|系统分类:科研笔记

某个依赖包安装不上,出现类似如下问题:

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be install

E: Unable to correct problems, you have held broken packages.

这个问题查询了好久,最终在这篇博客中找到了解决方法  https://blog.csdn.net/makenothing/article/details/23686141


具体做法是 安装 sudo apt-get install aptitude

解释一下 aptitude 这个词几乎就等价与apt-get,只不过与 apt-get 不同的是,aptitude在处理依赖问题上更佳一些。举例来说,aptitude在删除一个包时,会同时删除本身所依赖的包。这样,系统中不会残留无用的包,整个系统更为干净。并且如果遇到上述情况:

使用 sudo aptitude install 软件名,安装过程中出现上述问题,会给出解决方案,我就是选择了将某个高版本的依赖包降到低版本后,完成安装的。




http://blog.sciencenet.cn/blog-858128-1249082.html

上一篇:读取GNSS的NMEA-GGA语句json文件
下一篇:Ubuntu编译nginx错误

0

该博文允许注册用户评论 请点击登录 评论 (0 个评论)

数据加载中...

Archiver|手机版|科学网 ( 京ICP备07017567号-12 )

GMT+8, 2021-3-7 08:21

Powered by ScienceNet.cn

Copyright © 2007- 中国科学报社

返回顶部